このページ:TOP ≫  Poser  またはTOP ≫ 失敗編

属するカテゴリ● Poser失敗編
一つ前の記事 ● トランスマップを作るときのTips
一つ後の記事 ● スムースポリゴンの特性

クロスシミュレーションで髪の毛を作る3(スムースポリゴンがおかしい?)

ひき続き、クロスシミュレーションで髪の毛を作っているが、、、
どーにも上手く行かなくて試行錯誤なのである(笑)

とりあえず、今ぶち当たっている問題がコレ。マウスを乗せてみて欲しい。

上の画像、スムースポリゴンをオンにした画像であるが、マウスカーソルを当てるとスムースポリゴンがオフの画像に切り替わる。

もちろん、スムースポリゴンの角度設定が間違っているなどと言う初歩的なミスではない。

見て頂くと解るが、部分的にスムースポリゴンが働いていないのである。
働いていない部分は、
default(ダイナミックグループ)と
softDecorated(ソフトグループ)
の境目であるっぽい。


ひょっとして、異なるマテリアルが隣接する部分ではスムースポリゴン
が効かないのか?と思い実験したが、そんな現象は再現出来なかった(´Д`;)



こんな風にマテリアル分けして。。。。

スムースポリゴンオンでレンダリング!

綺麗にスムースかかっています。。。。。

Vueの様に、閉じたポリゴンは綺麗にスムース掛かるが、開くとダメなのか?

という事で板ポリで再度実験。

こんなの作って

Poserでスムースポリゴンをオン!

ちゃんと丸まっていますね。。。。

んでは、ダイナミッククロス化して、両端をソフトグループと強制グループに指定してレンダリングしてみよう。

で、出来た画像がコレ。

むむむむ。。。。。ちゃんとスムース化されていますね。。。

という事で、どうやら推論は間違っていた模様。


そういえば、髪の毛作る時、誤ってポリを切断して結合し直した。。。。
それが原因か?

と、いう事で、
さっきの球体を、このようにカットし。。。


同じ位置に貼り付け、近接する頂点をくっつける



で、出来たボールをPoserでレンダリング

ちゃんとスムースかかってます。。。。



板ポリでも同じでした。。。。


クロスシミュレーションしても大丈夫。。。。

という事で、あと思いつくのは、PCメモリが足りないか、作る時に よく解らない操作ミスをしてしまったか、どちらかだろうと推測し、髪の毛プロップを作り直す事にしますorz

Category : Poser, 失敗編
« トランスマップを作るときのTips(一つ古い記事) | このページ | スムースポリゴンの特性(一つ新しい記事) »
このブログを検索
カテゴリー
最近の記事
DAZ rendero e-on smithmicro e-frontier

関連項目

カテゴリPoser
カテゴリ失敗編

トラックバック

このエントリーのトラックバックURL:
http://www.boktv.x0.com/blog/b4tt8bbx.cgi/94-del
-delを削除してご使用ください(スパム対策)

コメント

コメントする




Posted by: ほげほげ | 2007年6月 3日 12:36

まさかとは思いますが、裏と表がひっくり返ってるとか…

Posted by: ぼくんちのTV けん | 2007年6月 4日 01:54

いつもアドバイスありがとうございます。

ポリゴンが途中から反転しているとスムースポリゴンが効かないと言うのは、全く知りませんでした。また一つ勉強になりました。

確かに途中でポリ分割して結合し直したので、その可能性は高かったのですが。。。。どうも今回は違ったみたいです。

今のプロップでもう少し実験してから、もう一度キチンとした髪の毛作り直してみます(^_^;